标签目录:elasticsearch

以下是与标签 “elasticsearch” 相关联的文章

Linux安装ElasticSearch

环境要求

1.Linux内核必须大于3.5以上
2.安装jdk1.8.0_121以上版本

注意事项

1.Linux内核版本小于3.5的,请更新内核
2.安装jdk1.8
3.不要使用root来运行。使用普通账号
4.修改 /etc/security/limits.conf

如果你的nofile值设置低于65536,会报错。比如,我设置成4096,会报如下错误

ERROR: [1] bootstrap checks failed
max file descriptors [4096] for elasticsearch process likely too low, increase to at least [65536]