首页 » LANMP » Linux » 正文

升级centos2.6中的python2.6到2.7

系统版本:CentOS6
因为Python 2.6核心团队不再支持Python 2.6,所以将系统的python版本升至2.7

下载python2.7

官网下载:https://www.python.org/downloads/

下载python2.7源码包
解压,并进入python源码目录


开始编译过程

如果需要重新编译,需要执行:

查看下新安装的python2.7的版本

建立软链接,将系统默认安装的python指向python2.7

再次查看python版本


修改yum使用的python版本

由于将系统默认的python2.6替换成python2.7后,yum是不兼容python2.7的,所以我们需要指定yum的python版本

将头部的
#!/usr/bin/python
改为
#!/usr/bin/python2.6

再次测试下yum是否正常
先卸载本机的wget

再次安装wget

OK,一切正常,收工!

发表评论

正在加载验证码......

请先完成验证