首页 » LANMP » php » 正文

安装swoole

先从编译安装php7.2开始

一.环境

  • centos 7
  • php7.2
  • swoole4.1.2

二.编译安装PHP 7.2

一些必要的软件

来到PHP源码下 :

然后 make && make install

设置环境变量

在该文件最后加上以下

执行source生效

把php路径设置到环境变量中

执行 php -v 如果正常出现则PHP安装好了

三.安装swoole

执行

然后稍等会
这里有些环境不一样的会有些坑,见执行 ‘pecl install swoole’之后,遇到的一些坑

配置php.ini
新装的php可能没有php.ini

  1. 执行php –ini 可以看到路径
  2. 可以在php的源码目录中找到php.ini-development ,改个名字拷贝到上面的目录下
  3. 修改php.ini 加入extension=swoole.so
  4. 执行php -m 如果出现swoole代表一切OK了

查看swoole版本及支持

如此则表示安装成功!

四.升级swoole

五.开发工具提示

https://github.com/eaglewu/swoole-ide-helper

配合IDE用,这里推荐phpstorm

发表评论

正在加载验证码......

请先完成验证