首页 » share » 正文

ubuntu16下安装OpenLdap

安装OpenLdap需要BerkeleyDB的支持,否则configure时会报 如下错误:

configure: error: BDB/HDB: BerkeleyDB not available

1.安装依赖库

2.安装BerkeleyDB

3.配置环境变量

wq保存后退出,使环境变量生效

4.复制文件

注意:如不按照以上步骤可能会报如下错误:

configure: error: Berkeley DB version mismatch

5.安装OpenLdap

注意: 在执行./configure的时候可能会报如下错误

configure: error: MozNSS not found – please specify the location to the NSPR and NSS header files in CPPFLAGS and the location to the NSPR and NSS libraries in LDFLAGS (if not in the system location)

原因是openldap需要依赖openssl的一些库文件,安装openldap,然后配置SSL的环境变量

发表评论

正在加载验证码......

请先完成验证